Infernal Linux file permissions...

For any tech-related problems

Moderator: Tech Moderators

User avatar
Mr.Clark
Posts: 4434
Joined: Mon Mar 19, 2007 8:57 am
Tag: ¯\_(ツ)_/¯

Infernal Linux file permissions...

Postby Mr.Clark » Thu Oct 08, 2015 10:38 pm

Basically, I've got three folders on my NAS mounted in a Linux VM on boot using fstab.

I had this working, but I had to change from a Windows domain controller to a Linux one, and even though the domain, usernames and passwords are all exactly the same, one of my three mounted folders has locked itself to read-only.

Here's the output from /etc/fstab:

Code: Select all

//NAS/TV /mnt/TV cifs dom=DOMAIN,username=USER,password=PASSWORD,uid=1000   0   0
//NAS/Films/HD /mnt/HD cifs dom=DOMAIN,username=USER,password=PASSWORD,uid=1000   0   0
//NAS/Films/SD /mnt/SD cifs dom=DOMAIN,username=USER,password=PASSWORD,uid=1000   0   0


and here's the output from the terminal when I copy and check the file permissions for the folders in /mnt/

Code: Select all

mint@mint-virtual-machine ~ $ sudo chmod --reference /mnt/SD /mnt/TV
mint@mint-virtual-machine ~ $ ls -l /mnt/
total 0
drwxrwxrwx 103 mint users 0 Sep 30 18:45 HD
drwxrwxrwx  13 mint users 0 Oct  8 21:05 SD
dr-xr-xr-x   5 mint users 0 Oct  8 21:55 TV


I've tried deleting /mnt/TV and re-creating it (just using sudo mkdir) and I've tried manually setting chmod 777, but it still doesn't give me the same drwxrwxrwx permissions that the working folders have.

Any Linux gurus able to assist?

User avatar
Mr.Clark
Posts: 4434
Joined: Mon Mar 19, 2007 8:57 am
Tag: ¯\_(ツ)_/¯

Re: Infernal Linux file permissions...

Postby Mr.Clark » Thu Oct 08, 2015 10:53 pm

Never mind, fixed it by using local permissions rather than domain ones. I forgot that every friggin' thing in Linux is case sensitive and the name of the NAS is in capitals.

Still not sure why it didn't work, and now I have two working domain logins and one local one, but hey, at least I can get to the files properly again...
The first rule of tautology club is the first rule of tautology club.

User avatar
RB
Posts: 10687
Joined: Sun Mar 18, 2007 3:27 pm

Re: Infernal Linux file permissions...

Postby RB » Thu Oct 08, 2015 11:07 pm

If you still need to set the permissions, try...

Code: Select all

sudo chmod 2777 /mnt/SD
sudo chmod 2777 /mnt/HD
sudo chmod -R 777 /mnt/SD
sudo chmod -R 777 /mnt/HD
A slight majority of a statistically worthless sample size agree.


Return to “Tech Help”

Who is online

Users browsing this forum: No registered users and 2 guests

cron